extension ExtPose

Password Caretaker

CRX id

hnefdambnaakgdhpomllhlaenobijalm-

Description from extension meta

A tool to safeguard your password security.

Image from store Password Caretaker
Description from store This is tool to generate safe passwords and verify if your current passwords are safe according to the 2017 NIST password guidelines. This extension provides a popup where you can verify if a password meets the NIST guidelines. You can also use this popup to generate safe, memorable passwords consisting of 7 common words and onetime passwords containing 20 random characters. This tool will also display an alert if you enter an unsafe password on a website. You should use this extension to ensure that all your passwords are safe and secure. It will detect if any of your current passwords are unsafe and enable you to generate safe, new passwords. It uses an API developed and maintained by security researcher Tony Hunt. This API only uses the first 5 digits of a SHA1 hash of a password to detect if it appears in a database of over 500 million breached passwords. You can learn more here: https://haveibeenpwned.com/Passwords This tool will reject passwords for the following reasons: - Password is too short. - Password is too short removing consecutive spaces. - Password is associated with username. - Password is associated with verifier. - Password contained too many repeated characters. - Password is a common word. - Password was found in a prior data breach. When a password is unsafe, the reason will be logged to the console. This is part of an open source project. The source code is available here: https://github.com/Gribbenator/password-caretaker

Statistics

Installs
Category
Rating
0.0 (0 votes)
Last update / version
2020-04-21 / 0.0.1
Listing languages

Links