extension ExtPose

OWA User-Agent

Description from extension meta

Allow the full version of Outlook Web Access (OWA) to be used in Chrome/Chromium in Linux, FreeBSD, and OSX.

Image from store OWA User-Agent
Description from store The problem: Microsoft Outlook Web Access sniffs the User Agent HTTP header* to see if the user is using Windows and delivers a poorer experience without. The solution: OWA-User-Agent is a simple plugin for Chrome that replaces the Linux UA string with one that is marked Windows so that full OWA can be used from within Linux and possibly OSX. This is open source software. Sources available here: https://github.com/jamiesonbecker/owa-user-agent No changes needed -- if the OWA URL contains /owa/ then it will work. Tested against two different enterprise installations of OWA. * For exactly this reason, the W3C considers user agent sniffing to be bad practice.

Latest reviews

  • (2019-03-21) Don M: Seems that the only way to use OWA is with this extension. Not happy that Microsoft has a user-agent sniffer to deliver worse performance on non Windows systems, but that's typical Microsoft behavior. This extension is a must have.
  • (2019-03-21) Brian Thompson: Simple and effective.
  • (2019-01-02) Ron Ronald: Thank God as I was ready to ship my new Google Slate back as any android app does not offer spell check so NO EMAIL CLIENTS will work for me. Total BS. This app now provides me to access my work email with a MUCH more enhanced version. THANK YOU
  • (2018-09-21) Andy Harrison: Running Chrome on Linux Mint, I was stuck in OWA enforced light version. Installed this extension, problem solved. Thanks!
  • (2018-08-16) Juan Ramírez: Works as advertised.
  • (2018-06-25) Christopher Hopper: Simple solution well implemented. Great for those of us using Google Chrome on a Linux desktop OS.
  • (2018-05-01) JP Seebo: OWA User-Agent is working for me in Opera. Use https://addons.opera.com/en/extensions/details/install-chrome-extensions/ then go to the chrome web store with Opera, find OWA and "Add To Opera"
  • (2017-12-20) Jeff Borello: Was using OWA Full for years, but then we upgraded to Exchange 2016 and it broke - was back to light mode and not happy about it. Pulled down this gem - and bam - right back to the full experience. Thank you so much - worked perfectly! Great job.
  • (2017-07-30) Sohib AL-Gotimel: i love it
  • (2017-04-17) Yes! Thank you for making this! =) I have a Chromebook, and was sending ugly, plain-text emails until I added your extension. Works perfectly!
  • (2017-04-07) Géza Kiss: Works perfectly! With this extension, I get e-mail notifications as well without having to refresh the page manually. I have no problem with attachments either.
  • (2017-03-05) Magnus Dahlerus: does not work!
  • (2017-02-17) John Klit Simonsen: Den har jeg ledt efter længe. Det virker rigtig godt.
  • (2016-12-14) Irina Svetlowa: Hi, I am interested in acquiring your extension "OWA User-Agent". Please contact me at: [email protected]
  • (2016-09-18) Stuart McIntyre: Exactly what I need but I always get the light version regardless of what I choose. I have had success with the Chrome UA spoofer extension but it is annoying having to turn that on an off.
  • (2015-12-16) J becker: Works great for me in Linux Chromium (37+) but Tim Nugent is right - can't attach files (have to log out and back in in light mode for that). I can't figure out why though. It's open source so you can audit the code.
  • (2015-10-19) Istvan Zakar: it should work if the link contains /OWA/, now I need to replace it manually.
  • (2015-09-24) Luca Weiss: Works perfectly!
  • (2015-09-17) Tim Nugent: Works ok but can't attach files to an email
  • (2015-06-30) Brian Rhees: Exactly what I needed without installing a full User-Agent extension. Thanks!
  • (2015-04-26) Virker fint.
  • (2015-02-03) D S: transformed my owa client. Thank you!
  • (2015-01-12) Carl Paetzel: Seems to work for me just fine. I get the 'Use Outlook Web Access Light' checkbox and am able to uncheck it in order to log in with full OWA. I do have the file upload problem that needs logging in with the light mode, so when I have to upload email attachments (fortunately, that's very rare) I have to log out and log back in. It's worth it to get the full OWA the rest of the time. Too bad MS doesn't fix it properly. @Ken Mills, try adding the / after 'owa' (ie /owa/). That might fix it for you?
  • (2014-11-26) Linda and Phil Fong: Works fine and is open source. Open source is important for a extension that can look at the content of all your webpages!
  • (2014-11-13) Ken Mills: This did not work for my OWA account. my account does show OWA in the address string. Great idea though.

Statistics

Installs
8,026 history
Category
Rating
4.3 (42 votes)
Last update / version
2017-06-18 / 0.1.1
Listing languages
en

Links